rvm 管理多版本 rails

先写再排版

原来本机上已经装有 ruby-2.1.4 + rails-4.1.2

现在想要装上 ruby-2.4.2 + rails-5.1.4

(1)安装 ruby-2.4.2

1、查看当前 rvm 中的 ruby 版本

$ rvm list

rvm rubies

=* ruby-2.1.4 [ x86_64 ]

# => - current
# =* - current && default
#  * - default

 

现在 rvm 中默认版本是 2.1.4 , 当前使用版本也是 2.1.4

2、 安装 2.4.2 版本

$ rvm install ruby-2.4.2

$ rvm list

rvm rubies

 * ruby-2.1.4 [ x86_64 ]
=> ruby-2.4.2 [ x86_64 ]

# => - current
# =* - current && default
#  * - default

现在 rvm 中默认版本是 2.1.4 , 当前使用版本也是 2.4.2

3、 设置 ruby 默认版本

$ rvm --default use 2.1.4

4、 设置当前使用的 ruby 版本

$ rvm use 2.4.2

(2) 安装 rails-5.1.4

1、创建一个专门的文件夹存放对应的 rails 版本

$ rvm gemset list

=> (default)
   global

目前有两个文件夹,现在再新增一个叫 rails5 的文件夹

$ rvm gemset create rails5

$ rvm gemset list

=> (default)
   global
   rails5

现在多了一个叫 rails5 的文件夹,切换到这个文件夹

$ rvm use 2.4.2@rails5

2、 获取 gems

$ bundle install -V(大写)

1、安装 rails-5.1.4

$ gem install rails --version=5.1.4

$ rails -v

Rails 5.1.4

(3)在各个版本之间切换

1、 默认版本

(1) 切换默认版本

$ rvm use default

$ ruby -v
ruby 2.1.4p265 (2014-10-27 revision 48166) [x86_64-linux]

rails -v
Rails 4.2.0

(2) 切换其他版本

$ rvm use 2.4.2@rails5

$ ruby -v
ruby 2.4.2p198 (2017-09-14 revision 59899) [x86_64-linux]

$ rails -v
Rails 5.1.4

(4) 要安装其他版本同理可得

相关文章

相关标签/搜索