综合试验

 

 

 

 

 

 

 

 

 

 

网络需求描述:
1、总公司按每个部门创建vlan,并分配相应的IP网段
      Vlan10-CWB(财务部)-192.168.10.0/24
      Vlan20-GLB(管理部)-192.168.20.0/24
      Vlan30-XXB(信息部)-192.168.30.0/24
      Vlan40-SRV(服务器区)-192.168.40.0/24
2、总公司内网要求实现vlan信息的统一管理和配置
3、总公司各部门之间可以相互访问
4、总公司内网要求实现二层链路的冗余备份
5、总公司内网要求实现网关冗余、流量负载分担
6、要求所有client动态获取IP地址
7、全网要求使用OSPF动态路由协议实现全网互通,并划分多区域
      a、总公司内网(OSPF Area0 type:backbone) 
      b、上海分支<--->总公司专线接口S1/1(OSPF Area11 type:Stub)
      c、深圳分支<--->总分司专线接口S1/0(OSPF Area22 type:Stub)
8、总公司、分支内网client可以访问互联网
9、总公司内网有台Web服务器需要发布到internet
10、利用ACL技术控制网络通信
        a、限制总公司的信息部client只在工作时间(周一至周五的9:00至17:30)可以上网
        b、限制总公司的财务部client只在休息时间(周一至周五的12:00至13:30)可以上网
        c、限制上海分支、深圳分支内网client只在周一至周五的9:00-12:00可以上网

-----------------------------------------------------------------------------------------------------------------------------------
实验配置步骤参考:
1、初始化设备

en
conf t
no ip do lo
line 0
logg sync
exec-t 0 0
host
2、创建Vlan,并启用中继链路
4506-S1的配置:
4506-S1#vlan database
4506-S1(vlan)#10 name CWB
4506-S1(vlan)#vlan 20 name GLB
4506-S1(vlan)#vlan 30 name XXB
4506-S1(vlan)#vlan 40 name SRV
4506-S1#exit
4506-S1(config)#int range f0/3 -7
4506-S1(config-if)sw mode trunk
4506-S1(config-if)#no sh
4506-S2的配置:
4506-S2(config)#int range f0/3 -7
4506-S2(config-if)#sw mode trunk
4506-S2(config-if)#no sh
3、配置VTP协议同步Vlan信息
4506-S1(vlan)#vtp domain haier.com
4506-S1(vlan)#vtp server
4506-S1(vlan)#vtp password 123
4506-S1(vlan)#vtp pruning
2960-S1(vlan)#vtp domain haier.com
2960-S1(vlan)#vtp server
2960-S1(vlan)#vtp password 123
4、在三层交换机间启快速以太网通道
4506-S1的配置:
4506-S1(config)#int range f0/5  -7
4506-S1(config-if)#channel-group 1 mode on
4506-S1(config-if)#no shutdown
4506-S2的配置:
4506-S2(config)#int range f0/5  -7
4506-S2(config-if)#channel-group 1 mode on
4506-S2(config-if)#no shutdown
5、在三层交换机上启路由端口,并给Vlan配置IP地址
4506-S1的配置:
4506-S1(config)#int f0/1
4506-S1(config-if)#no switchport
4506-S1(config-if)#ip add 192.168.1.2 255.255.255.0
4506-S1(config-if)#no shutdown
4506-S1(config)#int vlan 10
4506-S1(config-if)#ip add 192.168.10.253 255.255.255.0
4506-S1(config)#int vlan 20
4506-S1(config-if)#ip add 192.168.20.253 255.255.255.0
4506-S2的配置:
4506-S2(config)#int f0/1
4506-S2(config-if)#no switchport
4506-S2(config-if)#ip add 192.168.2.2 255.255.255.0
4506-S2(config-if)#no shutdown
4506-S2(config)#int vlan 10
4506-S2(config-if)#ip add 192.168.10.254 255.255.255.0
4506-S2(config)#int vlan 20
4506-S2(config-if)#ip add 192.168.20.254 255.255.255.0
6、在三层交换机上配置PVST+主、备根网桥
4506-S1的配置:
4506-S1(config)#spanning-tree vlan 10 root primary
4506-S1(config)#spanning-tree vlan 20 root primary
4506-S1(config)#spanning-tree vlan 30 root secondary
4506-S1(config)#spanning-tree vlan 40 root secondary
4506-S2的配置:
4506-S2(config)#spanning-tree vlan 10 root secondary
4506-S2(config)#spanning-tree vlan 20 root secondary
4506-S2(config)#spanning-tree vlan 30 root primary
4506-S2(config)#spanning-tree vlan 40 root primary
7、在接入层交换机上启Uplinkfast、Portfast特性
2960-S1的配置:
2960-S1(config)#spanning-tree uplinkfast
2960-S1(config-if)#int f0/3
2960-S1(config-if)#spanning-tree portfast
2960-S2的配置:
2960-S2(config)#spanning-tree uplinkfast
2960-S2(config-if)#int f0/3
2960-S2(config-if)#spanning-tree portfast
8、在三层交换机上配置HSRP实现网关冗余
4506-S1的配置:
4506-S1#(config)#int vlan 10
4506-S1#(config-if)#standby 10 ip 192.168.10.252
4506-S1#(config-if)#standby 10 priority 200
4506-S1#(config-if)#standby 10 preempt
4506-S1#(config)#int vlan 20
4506-S1#(config-if)#standby 20 ip 192.168.20.252
4506-S1#(config-if)#standby 20 priority 200
4506-S1#(config-if)#standby 20 preempt
4506-S2的配置:
4506-S2#(config)#int vlan 10
4506-S2#(config-if)#standby 10 ip 192.168.10.252
4506-S2#(config-if)#standby 10 priority 150
4506-S2#(config-if)#standby 10 preempt
4506-S2#(config)#int vlan 20
4506-S2#(config-if)#standby 20 ip 192.168.20.252
4506-S2#(config-if)#standby 20 priority 150
4506-S2#(config-if)#standby 20 preempt
9、部署Windows DHCP服务器,并新建作用域


10、在三层交换机上配置DHCP中继代理
4506-S1的配置:
4506-S1#(config)#int vlan 10
4506-S1#(config-if)#ip helper-address 192.168.40.1
4506-S1#(config)#int vlan 20
4506-S1#(config-if)#ip helper-address 192.168.40.1
4506-S2的配置:
4506-S2#(config)#int vlan 10
4506-S2#(config-if)#ip helper-address 192.168.40.1
4506-S2#(config)#int vlan 20
4506-S2#(config-if)#ip helper-address 192.168.40.1
11、配置OSPF动态路由协议
BJ-7206的配置:
BJ-7206(config)#router ospf 1
BJ-7206(config-router)#network 192.168.1.1 0.0.0.0 area 0
BJ-7206(config-router)#network 192.168.2.1 0.0.0.0 area 0
BJ-7206(config-router)#network 192.168.11.1 0.0.0.0 area 11
BJ-7206(config-router)#network 192.168.22.1 0.0.0.0 area 22
BJ-7206(config-router)#area 11 stub
BJ-7206(config-router)#area 22 stub
BJ-7206(config-router)#default-information originate
SH-2811的配置:
SH-2811(config)#router ospf 1
SH-2811(config-router)#network 192.168.11.2 0.0.0.0 area 11
SH-2811(config-router)#area 11 stub
SZ-2811的配置:
SZ-2811(config)#router ospf 1
SZ-2811(config-router)#network 192.168.22.2 0.0.0.0 area 22
SZ-2811(config-router)#area 22 stub
4506-S1的配置:
4506-S1(config)#router ospf 1
4506-S1(config-router)#network 0.0.0.0 0.0.0.0 area 0
4506-S2的配置:
4506-S2#(config)#router ospf 1
4506-S2#(config-router)#network 0.0.0.0 0.0.0.0 area 0
12、在边界路由器上配置PAT实现client访问internet
BJ-7206的配置:
BJ-7206(config)#access-list 1 permit  192.168.10.0 0.0.0.255
BJ-7206(config)#access-list 1 permit  192.168.20.0 0.0.0.255
BJ-7206(config)#access-list 1 permit  192.168.30.0 0.0.0.255
BJ-7206(config)#access-list 1 permit  192.168.12.0 0.0.0.255
BJ-7206(config)#access-list 1 permit  192.168.13.0 0.0.0.255
BJ-7206(config)#ip nat inside source list 1 interface e0/0 overload
BJ-7206(config)#int e0/0
BJ-7206(config-if)#ip nat outside
BJ-7206(config)#int e0/1
BJ-7206(config-if)#ip nat inside
BJ-7206(config)#int e0/2
BJ-7206(config-if)#ip nat inside
BJ-7206(config)#int S1/1
BJ-7206(config-if)#ip nat inside
BJ-7206(config)#int S1/0
BJ-7206(config-if)#ip nat inside
13、在边界路由器上配置Static NAT将Web服务器发布到internet
BJ-7206(config)#ip nat inside source static tcp 192.168.40.1 www int e0/0 www
14、通过ACL控制网络通信
BJ-7206的配置:
BJ-7206(config)#time-range CWB
BJ-7206(config-time-range)#periodic weekdays 12:00 to 13:30
BJ-7206(config)#time-range XXB
BJ-7206(config-time-range)#periodic weekdays 9:00 to 17:30
BJ-7206(config)#time-range BRANCH
BJ-7206(config-time-range)#periodic weekdays 9:00 to 12:00
BJ-7206(config)#ip access-list extend control
BJ-7206(config-ext-nacl)#permit tcp 192.168.10.0 0.0.0.255 any eq www time-range CWB
BJ-7206(config-ext-nacl)#permit tcp 192.168.30.0 0.0.0.255 any eq www time-range XXB
BJ-7206(config-ext-nacl)#permit tcp 192.168.12.0 0.0.0.255 any eq www time-range BRANCH
BJ-7206(config-ext-nacl)#permit tcp 192.168.13.0 0.0.0.255 any eq www time-range BRANCH
BJ-7206(config-ext-nacl)#permit OSPF any any
BJ-7206(config-ext-nacl)#permit tcp host 192.168.40.1 eq www any
BJ-7206(config-ext-nacl)#deny ip any any
BJ-7206(config)#int e0/1
BJ-7206(config-if)#ip access-group control in
BJ-7206(config)#int e0/2
BJ-7206(config-if)#ip access-group control in
BJ-7206(config)#int s1/0
BJ-7206(config-if)#ip access-group control in
BJ-7206(config)#int s1/1
BJ-7206(config-if)#ip access-group control in
15、测试 show int trunk show vlan-sw brief show spanning-tree brief show ip nat translation show access-list

相关文章