不能在centos上安装php-devel

我需要帮助安装php-devel(我需要它,因为它有phpize,这是必要的安装eAccelerator).但是当我尝试使用yum安装php-devel安装php-devel时,会给我以下错误:

# yum install php-devel
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * base: centos.itt-consulting.com
 * epel: mirror.yandex.ru
 * extras: centos.itt-consulting.com
 * passenger: mirror.hmdc.harvard.edu
 * updates: centos.itt-consulting.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-devel.x86_64 0:5.3.3-14.el6_3 will be installed
--> Processing Dependency: php = 5.3.3-14.el6_3 for package: php-devel-5.3.3-14.el6_3.x86_64
--> Finished Dependency Resolution
Error: Package: php-devel-5.3.3-14.el6_3.x86_64 (updates)
           Requires: php = 5.3.3-14.el6_3
           Installed: php-5.4.6-1.el6.remi.x86_64 (@remi-test)
               php = 5.4.6-1.el6.remi
           Available: php-5.3.3-3.el6_2.8.x86_64 (base)
               php = 5.3.3-3.el6_2.8
           Available: php-5.3.3-14.el6_3.x86_64 (updates)
               php = 5.3.3-14.el6_3
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

我不知道如何处理这些错误.而且我有php 5.3.3安装(phpinfo()说),所以不明白为什么在这个列表中我可以看到Installed:php-5.4 …

而不是运行yum install php-devel你需要运行yum –enablerepo = remi,remi-php54 install php-devel.

简而言之,只需从remi repo中指定您想要的php-devel版本.在你的情况下,你从remi安装了php54,所以你需要添加“remi-php54”.这样可以在没有停机的情况下成功安装php-devel.

相关文章
相关标签/搜索