macOS打造Web前端开发环境及高效管理macOS

Ren Chunhui's Dotfiles

本配置比较适合Web前端开发人员,打造 iTerm + Zsh + Vim/NeoVim + Tmux] 开发,自动补全使用效率好的YouCompleteMe(已解决YouCompleteMe安装却提示需要Python的问题)

提示安装常用工具及App,如使用工具不一样的,可自已进行相关配置

详细配置: https://github.com/RenChunhui...

安装

$ git clone https://github.com/RenChunhui/dotfiles.git .dotfiles
$ cd .dotfiles
$ chmod +x ./install.sh
$ ./install.sh

Vim & NeoVim 安装

插件YouCompleteMe所需的Python已在初使化环境中配置完成

适合前端 Vue、React.js、Typescript 相关开发,

$ cd ~/.vim/plugged/YouCompleteMe
$ ./install.py --js-completer

Vim

NeoVim

YouCompleteMe

macOS 设置

$ cd scripts
$ chmod +x ./osx.sh
$ ./osx.sh

参考

许可证

MIT license.

相关文章
相关标签/搜索