.net – 为Outlook 2010加载项创建设置

我创建了一个outlook加载项,需要创建一个设置以使其可分发(我是新手,所以请原谅新手评论)

Outlook -2010
Vs  -2010
.Net 4.0

我读了一些,最简单的方法就是发布.是的,这很简单.设置已创建,我可以安装.
问题是,在没有.net 4.0(或者可能是VS 2010)的系统中,设置开始首先安装框架(这很好.. :))重启系统(完全安装4.0).
当用户尝试安装设置时,会出错提示:

the following solution cannnot be loaded because Microsoft Office
support for the .Net framework 4.0 is not installed

用户计算机最初具有Outlook 2010和框架3.5.我检查并安装了4.0客户端(约33 MB).

我最近遇到了同样的问题,并且必须在安装我的加载项之前在客户端工作站上安装Office Runtime的Visual Studio 2010工具.安装后,我立即能够安装我的插件而无需重启.

根据VSTO团队的[post] [3]:

Note that in the Beta and RTM releases of Office 2010 you will NOT get Office 4.0 Runtime Extensions (or the capability for them to be “turned on”). If you are deploying customizations that target .Net Framework 4 and they will run on Office 2010 you will need your users to install the VSTO 2010 Runtime redistributable (and of course before their customization will run they will have to install .Net Framework 4).

相关文章
相关标签/搜索