如何更新IntellijIdea使用的Maven版本

我尝试在IntellijIdea中打开Maven项目.这个项目使用spark和 scala.当我跑:

mvn clean install -DskipTests

然后它给出错误:

[ERROR] Failed to execute goal
org.scalastyle:scalastyle-maven-plugin:0.7.0:check (default) on
project spark-mllib_2.10: Failed during scalastyle execution: You have
50 Scalastyle violation(s)

我认为问题出在Maven的版本中.确实在IntellijIdea设置中我有版本Bundled(Maven 3)3.0.5,而pom.xml定义< maven.version> 3.3.3< /maven.version\u0026gt;
如果我在终端中运行mvn -version,它指向Maven 3.3.3

那么,我如何更新IntellijIdea使用的Maven版本?

>安装新版本的maven(如果尚未安装) >转到文件 – >设置并使用搜索栏查找maven设置 >编辑Maven主目录设置,使其指向所需版本的安装文件夹
相关文章
相关标签/搜索