symfony – Composer,最小稳定性和依赖关系的依赖关系

我在使用作曲家的新项目和Symfony 2依赖项时非常挑剔.

首先,我使用composer安装symfony / framework-standard-edition v2.1.5.这会产生一个具有这些要求且没有最小稳定性节点的composer文件.

"require": {
  "php": ">=5.3.3",
  "symfony/symfony": "2.1.*",
  "doctrine/orm": ">=2.2.3,<2.4-dev",
  "doctrine/doctrine-bundle": "1.0.*",
  "twig/extensions": "1.0.*@dev",
  "symfony/assetic-bundle": "2.1.*",
  "symfony/swiftmailer-bundle": "2.1.*",
  "symfony/monolog-bundle": "2.1.*",
  "sensio/distribution-bundle": "2.1.*",
  "sensio/framework-extra-bundle": "2.1.*",
  "sensio/generator-bundle": "2.1.*",
  "jms/security-extra-bundle": "1.2.*",
  "jms/di-extra-bundle": "1.1.*",
  "kriswallsmith/assetic": "1.1.*@dev"
},

这很好用,它安装所有最新的稳定版本,就像它应该的那样.

接下来,我添加一个包 – > https://packagist.org/packages/kunstmaan/admin-bundle

"require": {
  "php": ">=5.3.3",
  "symfony/symfony": "2.1.*",
  "doctrine/orm": ">=2.2.3,<2.4-dev",
  "doctrine/doctrine-bundle": "1.0.*",
  "twig/extensions": "1.0.*@dev",
  "symfony/assetic-bundle": "2.1.*",
  "symfony/swiftmailer-bundle": "2.1.*",
  "symfony/monolog-bundle": "2.1.*",
  "sensio/distribution-bundle": "2.1.*",
  "sensio/framework-extra-bundle": "2.1.*",
  "sensio/generator-bundle": "2.1.*",
  "jms/security-extra-bundle": "1.2.*",
  "jms/di-extra-bundle": "1.1.*",
  "kriswallsmith/assetic": "1.1.*@dev",
  "kunstmaan/admin-bundle": "dev-master"
},

这个捆绑包取决于“dev-master”中的“doctrine / doctrine-fixtures-bundle”(https://packagist.org/packages/doctrine/doctrine-fixtures-bundle)

而那捆绑依赖于学说/数据夹具*(https://packagist.org/packages/doctrine/data-fixtures)

现在,当我在项目中运行composer update时,它告诉我没有什么可以满足doctrine / data-fixtures依赖.名称中的拼写错误,或者没有“稳定”版本可用,因为最小稳定性默认为稳定.

它确实想要在“dev”稳定性中安装doctrine-fixtures-bundle,因为put-master会自动将这种依赖性置于“dev”稳定性中.但这对于这个dep的deps没有任何作用,他们一直希望安装稳定,因为这是我的最小稳定性.

在这一点上,我可以通过在项目中将doctrine / data-fixture:dev-master或@dev添加到我的composer.json中来解决这个问题.

但由于这只是一个例子(knpmenubundle,fosuserbundle等等),我将不得不手动去添加所有不安装到我自己的作曲家文件的deps deps.

另一个解决方案是将我的项目的最小稳定性降低到dev,但那时我所有的deps,包括像Symfony2这样的稳定​​版本,都将安装他们的dev版本而不是标记版本.

只有一个好方法:唠叨人们,以便他们标记更多的版本.如果你真的需要处理不稳定的东西,那么将它们全部列入白名单需要“@dev”是最好的替代IMO.如果你有比稳定更不稳定的东西,那么你总是可以标记@stable并将最小稳定性设置为dev.在大多数情况下,仍然有锁文件来保存你的屁股;)
相关文章
相关标签/搜索