反应本机 – RNMK – 超级表达式必须为null或函数

将项目升级到React-Native 0.26后,应用程序会崩溃,出现以下错误:

“Super expression must either be null or a function, not undefined”

它在Switch.js文件中崩溃,该文件属于React-Native-Material-Kit包.

enter image description here

啊,这是因为React-Native正在快速移动!我的选择太快了在25我们看到这个警告:

弃用

现在不推荐使用反应原子的反应API – 2eafcd4 0b534d1

代替:

import React, { Component, View } from 'react-native';

你现在应该:

import React, { Component } from 'react';
import { View } from 'react-native';

而在26年之后只有一个发布,现在是breaking change

你可以尝试这个codemod,如果你敢的话.我正在做一个手动更改.

相关文章
相关标签/搜索