在vmware中从我的ubuntu运行kafka时无法识别的VM选项’UseCompressedOops’

我正在使用VMware与ubuntu合作
我已经安装了hadoop单节点集群.
然后我安装了zookeeper并运行了zookeeper.
然后,当我运行我的“Apache kafka”时,它会抛出一个错误.

无法识别的VM选项’UseCompressedOops’

无法创建Java虚拟机

单个@ ubuntu:〜/ yoga / zookeeper-3.4.5 / bin $./zkServer.sh启动

默认情况下启用JMX

使用config:/home/single/yoga/zookeeper-3.4.5/bin/../conf/zoo.cfg

开始动物园管理员……开始了

single @ ubuntu:〜/ yoga / kafka_2.8.0-0.8.0 $bin / kafka-server-start.sh config / server.properties

无法识别的VM选项’UseCompressedOops’

无法创建Java虚拟机.

由于您的VM不支持“UseCompressedOops”选项.要修复它,请从kafka的配置中删除该选项,这将帮助您启动两个(zookeeper& kafka)服务器.

1)转到Kafka安装目录:

cd kafka_2.8.0-0.8

2)编辑Kafka的类路径设置器脚本:

vi bin/kafka-run-class.sh

3)搜索“KAFKA_JVM_PERFORMANCE_OPTS”令牌&从该行中删除’-XX:UseCompressedOops’.

即,在删除之前:

KAFKA_JVM_PERFORMANCE_OPTS="-server -XX:+UseCompressedOops -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:+CMSClassUnloadingEnabled -XX:+CMSScavengeBeforeRemark -XX:+DisableExplicitGC -Djava.awt.headless=true"

删除后:

KAFKA_JVM_PERFORMANCE_OPTS="-server -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:+CMSClassUnloadingEnabled -XX:+CMSScavengeBeforeRemark -XX:+DisableExplicitGC -Djava.awt.headless=true"

4)启动你的动物园管理员和kafka服务器实例

./bin/zookeeper-server-start.sh config/zookeeper.properties
./bin/kafka-server-start.sh config/server.properties
相关文章
相关标签/搜索