修复“警告:未找到GMP或MPIR库;不使用CentOS 6.4在Python 2.7上构建Crypto.PublickKey._fastmath“错误

我正在使用带有 Python 2.7(通过PythonBrew脚本安装)的CentOS 6.4服务器

我通过’yum install gmp’安装gmp
和python-devel安装通过’yum安装python-devel'(但它是为python 2.6系列)

我试图在我的服务器上安装pycrypto,但它是给我的

warning: GMP or MPIR library not found; Not building Crypto.PublickKey._fastmath

有没有办法让点’识别’我的gmp安装?

感谢:D

尝试在Centos 6.4系统级使用pip安装Fabric时遇到上述错误. (Fabric使用pycrypto).

warning: GMP or MPIR library not found; Not building Crypto.PublickKey._fastmath

这是我如何工作的:

yum install gmp-devel
sudo pip uninstall ecdsa pycrypto paramiko fabric 
# clear out the pip build dirs
rm -rf /tmp/pip-*
# make sure the directory containing libgmp.so.3 is on the python path
export LD_LIBRARY_PATH="/usr/lib64:$LD_LIBRARY_PATH"  
pip install fabric
相关文章
相关标签/搜索