haskell – yesod-bin缺少(未知)依赖?

如何安装yesod可执行文件?

> cabal install yesod-bin
Resolving dependencies...
cabal: Could not resolve dependencies:
trying: yesod-bin-1.2.0

所以它没有告诉我缺少的实际依赖.

以前一切都很好.我将我的linux操作系统更新为Suse12.3,然后yesod抱怨了几十个破坏的依赖项.所以我卸载了ghc,在我的主目录中删除了.ghc和.cabal,重新安装了haskell-platform,做了cabal更新,然后cabal安装yesod-platform,这一切都很顺利.注意到缺少yesod二进制文件,我发现了有关Yesod 1.2发布的博客文章,并尝试安装yesod-bin,现在失败但没有有用的错误消息.即使增加详细程度也不会向我提供任何有用的信息:

> ghc --version
The Glorious Glasgow Haskell Compilation System, version 7.4.2

> cabal --verbose=3 install yesod-bin 
searching for ghc in path.
found ghc at /usr/bin/ghc
("/usr/bin/ghc",["--numeric-version"])
/usr/bin/ghc is version 7.4.2
looking for tool "ghc-pkg" near compiler in /usr/bin
found ghc-pkg in /usr/bin/ghc-pkg
("/usr/bin/ghc-pkg",["--version"])
/usr/bin/ghc-pkg is version 7.4.2
("/usr/bin/ghc",["--supported-languages"])
("/usr/bin/ghc",["--info"])
Reading installed packages...
("/usr/bin/ghc-pkg",["dump","--global","-v0"])
("/usr/bin/ghc-pkg",["dump","--user","-v0"])
("/usr/bin/ghc",["--print-libdir"])
Reading available packages...
Choosing modular solver.
Resolving dependencies...
[__0] trying: yesod-bin-1.2.0
[__1] rejecting: base-3.0.3.2, 3.0.3.1 (global constraint requires installed instance)
[__1] trying: base-4.5.1.0/installed-6e4...
[__2] trying: rts-1.0/installedbuil...
[__3] trying: integer-gmp-0.4.0.0/installed-af3...
[__4] trying: ghc-prim-0.2.0.0/installed-7d3...
[__5] trying: wai-1.4.0/installed-3a1...
[__6] trying: vault-0.2.0.4/installed-2b6...
[__7] trying: hashable-1.2.0.7/installed-d66...
[__8] trying: warp-1.3.8.1/installed-ace...
[__9] trying: void-0.6/installed-a34...
[_10] trying: semigroups-0.9.1/installed-e88...
[_11] trying: nats-0.1/installed-b6a...
[_12] trying: unix-2.5.1.1/installed-48f...
[_13] trying: simple-sendfile-0.2.11/installed-74a...
[_14] trying: case-insensitive-1.0.0.1/installed-709...
[_15] trying: deepseq-1.3.0.0/installed-c26...
[_16] trying: array-0.4.0.0/installed-0b6...
[_17] trying: blaze-builder-conduit-1.0.0/installed-3d2...
[_18] trying: transformers-0.3.0.0/installed-8e6...
[_19] trying: project-template-0.1.3
[_20] trying: project-template-0.1.3:!test
[_21] trying: mtl-2.1.2/installed-02e...
[_22] trying: base64-conduit-1.0.0
[_23] trying: base64-conduit-1.0.0:!test
[_24] trying: classy-prelude-0.5.4
[_25] trying: classy-prelude-0.5.4:!test
[_26] trying: vector-0.10.0.1/installed-345...
[_27] trying: primitive-0.5.0.1/installed-15c...
[_28] trying: basic-prelude-0.3.5.0
[_29] trying: ReadArgs-1.2.1
[_30] trying: ReadArgs-1.2.1:!test
[_31] trying: network-conduit-1.0.0/installed-073...
[_32] trying: monad-control-0.3.2.1/installed-325...
[_33] trying: transformers-base-0.4.1/installed-8ce...
[_34] trying: base-unicode-symbols-0.2.2.4/installed-47d...
[_35] trying: http-conduit-1.9.3/installed-ef7...
[_36] trying: zlib-conduit-1.0.0/installed-285...
[_37] trying: zlib-bindings-0.1.1.3/installed-ef4...
[_38] trying: utf8-string-0.3.7/installed-3aa...
[_39] trying: tls-extra-0.6.1/installed-a7d...
[_40] trying: pem-0.1.2/installed-6f3...
[_41] trying: cereal-0.3.5.2/installed-807...
[_42] trying: cryptohash-0.9.0/installed-4c8...
[_43] trying: tagged-0.6/installed-8e1...
[_44] trying: crypto-api-0.12/installed-07e...
[_45] trying: entropy-0.2.1/installed-b34...
[_46] trying: crypto-random-api-0.2.0/installed-dd2...
[_47] trying: crypto-pubkey-0.1.3/installed-e49...
[_48] trying: crypto-pubkey-types-0.3.2/installed-0f2...
[_49] trying: asn1-types-0.1.3/installed-29c...
[_50] trying: crypto-numbers-0.1.3/installed-c6e...
[_51] trying: cipher-rc4-0.1.2/installed-854...
[_52] trying: cipher-aes-0.1.8/installed-aaa...
[_53] trying: tls-1.1.2/installed-106...
[_54] trying: socks-0.5.1/installed-1e3...
[_55] trying: regex-compat-0.95.1/installed-cc3...
[_56] trying: regex-posix-0.95.2/installed-417...
[_57] trying: regex-base-0.93.2/installed-920...
[_58] trying: random-1.0.1.1/installed-a21...
[_59] trying: publicsuffixlist-0.1/installed-7c1...
[_60] trying: mime-types-0.1.0.3/installed-f07...
[_61] trying: failure-0.2.0.1/installed-579...
[_62] trying: data-default-0.5.3/installed-f33...
[_63] trying: data-default-instances-old-locale-0.0.1/installed-e48...
[_64] trying: old-locale-1.0.0.4/installed-5e4...
[_65] trying: data-default-instances-dlist-0.0.1/installed-ec3...
[_66] trying: dlist-0.5/installed-0a8...
[_67] trying: data-default-instances-containers-0.0.1/installed-a88...
[_68] trying: data-default-instances-base-0.0.1/installed-2ea...
[_69] trying: data-default-class-0.0.1/installed-404...
[_70] trying: cprng-aes-0.3.4/installed-bc2...
[_71] trying: cookie-0.4.0.1/installed-9d9...
[_72] trying: certificate-1.3.7/installed-d6c...
[_73] trying: asn1-data-0.7.1/installed-8ec...
[_74] trying: network-2.3.1.0/installed-efa...
[_75] trying: http-reverse-proxy-0.1.1.6
[_76] trying: http-reverse-proxy-0.1.1.6:!test
[_77] trying: word8-0.0.3/installed-366...
[_78] trying: lifted-base-0.2.0.4/installed-1f9...
[_79] trying: base64-bytestring-1.0.0.1/installed-ffa...
[_80] trying: resourcet-0.4.7.1/installed-45e...
[_81] trying: mmorph-1.0.0/installed-19c...
[_82] trying: conduit-1.0.5/installed-a38...
[_83] trying: file-embed-0.0.4.7/installed-004...
[_84] trying: split-0.2.1.1/installed-03e...
[_85] trying: fsnotify-0.0.11
[_86] trying: fsnotify-0.0.11:!test
[_87] trying: hinotify-0.3.5
[_88] trying: hinotify-0.3.5:+split-base
[_89] trying: optparse-applicative-0.5.2.1
[_90] trying: optparse-applicative-0.5.2.1:!test
[_91] trying: yaml-0.8.2.4/installed-68e...
[_92] trying: aeson-0.6.1.0/installed-9bd...
[_93] trying: syb-0.3.7/installed-60a...
[_94] trying: unordered-containers-0.2.3.1/installed-55f...
[_95] trying: system-fileio-0.3.11/installed-2fc...
[_96] trying: system-filepath-0.4.7/installed-977...
[_97] trying: tar-0.4.0.1
[_98] trying: old-time-1.1.0.0/installed-703...
[_99] trying: zlib-0.5.4.0/installed-f9a...
[100] trying: process-1.1.0.1/installed-608...
[101] trying: filepath-1.3.0.0/installed-f99...
[102] trying: blaze-builder-0.3.1.1/installed-536...
[103] trying: http-types-0.8.0/installed-a08...
[104] trying: attoparsec-0.10.4.0/installed-c39...
[105] trying: containers-0.4.2.1/installed-75f...
[106] trying: unix-compat-0.4.1.1/installed-35c...
[107] trying: directory-1.1.0.2/installed-c30...
[108] trying: template-haskell-2.7.0.0/installed-2bd...
[109] trying: pretty-1.1.1.0/installed-91e...
[110] trying: time-1.4/installed-d61...
[111] trying: bytestring-0.9.2.1/installed-503...
[112] trying: shakespeare-css-1.0.5.1/installed-013...
[113] trying: shakespeare-js-1.1.4/installed-df8...
[114] trying: shakespeare-1.0.5/installed-9c1...
[115] trying: shakespeare-text-1.0.0.5
[116] trying: shakespeare-text-1.0.0.5:!test
[117] trying: text-0.11.2.3/installed-db6...
[118] trying: parsec-3.1.3/installed-771...
[119] rejecting: ghc-paths-0.1.0.9 (unknown package: ghc)
[__0] fail (backjumping, conflict set: ghc, yesod-bin)
cabal: Could not resolve dependencies:
trying: yesod-bin-1.2.0
有些发行版不包含haskell-platform中的ghc库包,我认为这是错误的.

这与cabal为未知包装产生非常糟糕的错误消息这一事实有关.

通过简要地查看opensuse包,看起来好像你需要ghc-ghc:http://software.opensuse.org/package/ghc-ghc

相关文章
相关标签/搜索