ruby-on-rails – 如何升级项目的Ruby版本?

我最近开始使用 Ruby 1.9.3p385学习Rails,我正在尝试用它开发一个小项目.

我正在使用Linux,因此我使用RVM安装了Ruby.

我开发了一些页面,遵循一些教程.我想升级我的项目以使用Ruby 2.0.0.我需要做什么?

我用RVM安装了Ruby 2.0.0:

rvm install 2.0.0

一切似乎都没问题,所以我试着用它:

rvm use 2.0.0-p247

但是当我尝试使用rails服务器运行我的Rails服务器时,我收到以下消息:

bash: rails : command not found

我读过RVM documentation about upgrading Ruby,但我真的不明白它的作用;我害怕打破一切.

它会以一种使用Ruby 2.0.0的方式升级我的项目,或者我应该怎么做?

接下来,我还想升级到Rails v4.

您的新Ruby版本附带的gemset是空的.试试这个:

gem install bundler # this will install bundler
bundle # this will use bundler to install required gems
rails server
相关文章
相关标签/搜索