PHP升级到5.5.11版本

1.首先升级yum install libmcrypt-devel

2.安装php

wget http://br1.php.net/get/php-5.5.11.tar.gz/from/this/mirror

tar zxvf php-5.5.11.tar.gz && cd php-5.5.11

./configure --prefix=/usr/local/php_5.5.11 --with-config-file-path=/usr/local/php_5.5.11/etc --with-mysql=/usr/local/mysql --with-mysqli=mysqlnd --with-iconv-dir=/usr/local --with-freetype-dir --with-jpeg-dir --with-png-dir --with-zlib --with-libxml-dir=/usr --enable-xml --disable-rpath --enable-bcmath --enable-shmop --enable-sysvsem --enable-inline-optimization --with-curl=/usr/local --without-curlwrappers --enable-mbregex --enable-fpm --enable-mbstring --with-mcrypt --with-gd --enable-gd-native-ttf --with-openssl --with-mhash --enable-pcntl --enable-sockets  --with-xmlrpc --enable-zip --enable-soap  --without-pear --enable-zip --with-bz2 --enable-calendar --enable-ftp --enable-ctype --enable-exif --disable-ipv6 --with-sqlite3 --disable-pdo --disable-phar
make ZEND_EXTRA_LIBS='-liconv'
make install

cp sapi/fpm/init.d.php-fpm /etc/init.d/php-fpm
chmod +x /etc/init.d/php-fpm
mkdir -p /usr/local/php_5.5.11/log
mkdir -p /usr/local/php_5.5.11/logs/
echo '/usr/local/mysql/lib/' > /etc/ld.so.conf.d/mysql.conf
ldconfig
3. 安装memcached扩展
cd ..

wget https://launchpad.net/libmemcached/1.0/1.0.14/+download/libmemcached-1.0.14.tar.gz

rm -rf libmemcached-1.0.14
tar zxf libmemcached-1.0.14.tar.gz  && cd libmemcached-1.0.14
./configure --prefix=/usr/local/libmemcached --with-memcached --disable-sasl
make && make install
提示错误:

./libmemcached-1.0/memcached.h:46:27: error: tr1/cinttypes: No such file or directory
make[1]: *** [libmemcached/libmemcached_libmemcached_la-allocators.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/tools/libmemcached-1.0.14'
make: *** [all] Error 2

libmemcached-1.0.14需要升级gcc、gcc++,否则编译编译失败
yum install gcc44 gcc44-c++ libstdc++44-devel
export CC=/usr/bin/gcc44
export CXX=/usr/bin/g++44

再执行

./configure --prefix=/usr/local/libmemcached --with-memcached --disable-sasl
make && make install


wget http://pecl.php.net/get/memcached-2.1.0.tgz
rm -rf memcached-2.1.0
tar zxvf memcached-2.1.0.tgz && cd memcached-2.1.0
/usr/local/php_5.5.11/bin/phpize
./configure --with-php-config=/usr/local/php_5.5.11/bin/php-config --enable-memcached --enable-memcached-json
yes|cp -r ../php-5.5.11/ext/json/ /usr/local/php_5.5.11/include/php/ext/
make && make install
提示错误:
make: *** [php_memcached.lo] Error 1
因此需要指定libmemcached路径:
./configure --with-php-config=/usr/local/php_5.5.11/bin/php-config --enable-memcached --enable-memcached-json -with-libmemcached-dir=/usr/local/libmemcached

make && make install


4.安装tokyo_tyrant扩展

wget http://pecl.php.net/get/tokyo_tyrant-0.7.0.tgz
tar zxvf tokyo_tyrant-0.7.0.tgz
cd tokyo_tyrant-0.7.0 && /usr/local/php_5.5.11/bin/phpize && ./configure --with-php-config=/usr/local/php_5.5.11/bin/php-config --with-tokyo-tyrant=/usr/local --with-tokyo-cabinet-dir=/usr/local && make && make install


5.安装redis扩展wget http://******/phpredis-nicolasff-20121217.tar.gztar zxvf phpredis-nicolasff-20121217.tar.gzcd phpredis-master/ && /usr/local/php_5.5.11/bin/phpize./configure --with-php-config=/usr/local/php_5.5.11/bin/php-config --enable-redis && make && make install  

相关文章
相关标签/搜索