API GateWay ---Kong 安装注意事项

如果系统(CentOS)中安装过openresty,则需要将其卸载,否则会报错

Transaction check error:
  file /usr/local/openresty/nginx/html/index.html from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/websocket/client.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/websocket/server.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/luajit/bin/luajit from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/luajit/include/luajit-2.1/lauxlib.h from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/luajit/include/luajit-2.1/lua.h from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/luajit/include/luajit-2.1/lua.hpp from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/luajit/include/luajit-2.1/luaconf.h from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/luajit/include/luajit-2.1/luajit.h from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/luajit/include/luajit-2.1/lualib.h from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/luajit/lib/libluajit-5.1.so.2.1.0 from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/luajit/lib/pkgconfig/luajit.pc from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/cjson.so from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/ngx/balancer.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/ngx/ocsp.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/ngx/re.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/ngx/semaphore.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/ngx/ssl.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/ngx/ssl/session.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/redis/parser.so from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/aes.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/core.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/core/base.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/core/base64.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/core/ctx.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/core/exit.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/core/hash.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/core/misc.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/core/regex.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/core/request.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/core/response.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/core/shdict.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/core/time.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/core/uri.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/core/var.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/core/worker.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/dns/resolver.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/limit/conn.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/limit/req.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/limit/traffic.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/lock.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/lrucache.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/lrucache/pureffi.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/md5.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/memcached.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/mysql.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/random.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/redis.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/sha.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/sha1.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/sha224.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/sha256.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/sha384.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/sha512.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/string.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/upload.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/upstream/healthcheck.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/lualib/resty/websocket/protocol.lua from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/nginx/conf/fastcgi.conf from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/nginx/conf/fastcgi.conf.default from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/nginx/conf/fastcgi_params from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/nginx/conf/fastcgi_params.default from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/nginx/conf/koi-utf from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/nginx/conf/koi-win from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/nginx/conf/mime.types from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/nginx/conf/mime.types.default from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/nginx/conf/nginx.conf from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/nginx/conf/nginx.conf.default from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/nginx/conf/scgi_params from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/nginx/conf/scgi_params.default from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/nginx/conf/uwsgi_params from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/nginx/conf/uwsgi_params.default from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/nginx/conf/win-utf from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/nginx/html/50x.html from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64
  file /usr/local/openresty/nginx/sbin/nginx from install of kong-community-edition-0.11.2-1.noarch conflicts with file from package openresty-1.11.2.5-2.el7.centos.x86_64

错误概要

直接运行 yum remove openresty

[root@docker1 spy]# sudo yum install kong-community-edition-0.11.2.*.noarch.rpm --nogpgcheck 已加载插件:fastestmirror 正在检查 kong-community-edition-0.11.2.el7.noarch.rpm: kong-community-edition-0.11.2-1.noarch kong-community-edition-0.11.2.el7.noarch.rpm 将被安装 正在解决依赖关系 --> 正在检查事务 ---> 软件包 kong-community-edition.noarch.0.0.11.2-1 将被 安装 --> 解决依赖关系完成 依赖关系解决

===========================================================================================================================================================================
 Package                                    架构                       版本                            源                                                             大小
===========================================================================================================================================================================
正在安装:
 kong-community-edition noarch 0.11.2-1 /kong-community-edition-0.11.2.el7.noarch 40 M

事务概要 ===========================================================================================================================================================================
安装  1 软件包

总计:40 M
安装大小:40 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
 正在安装 : kong-community-edition-0.11.2-1.noarch 1/1
 验证中 : kong-community-edition-0.11.2-1.noarch 1/1

已安装:
 kong-community-edition.noarch 0:0.11.2-1

完毕!
[root@docker1 ]# kong version
0.11.2
相关文章
相关标签/搜索