npm ERR! missing: core-util-is@^1.0.2, required by Administrator

1、错误描述

C:\Users\Administrator>npm list
C:\Users\Administrator
+-- babel-core@5.8.38 extraneous
+-- UNMET DEPENDENCY core-util-is@^1.0.2
+-- grunt@1.0.2 extraneous
+-- UNMET DEPENDENCY process-nextick-args@^2.0.0
+-- UNMET DEPENDENCY util-deprecate@^1.0.2
+-- vue@2.2.6 extraneous
`-- webpack-cli@2.1.4 extraneous

npm ERR! missing: core-util-is@^1.0.2, required by Administrator
npm ERR! missing: process-nextick-args@^2.0.0, required by Administrator
npm ERR! missing: util-deprecate@^1.0.2, required by Administrator
npm ERR! extraneous: babel-core@5.8.38 C:\Users\Administrator\node_modules\babel
-core
npm ERR! extraneous: grunt@1.0.2 C:\Users\Administrator\node_modules\grunt
npm ERR! extraneous: vue@2.2.6 C:\Users\Administrator\node_modules\vue
npm ERR! extraneous: webpack-cli@2.1.4 C:\Users\Administrator\node_modules\webpa
ck-cli

C:\Users\Administrator>cnpm list
npm WARN npm npm does not support Node.js v10.3.0
npm WARN npm You should probably upgrade to a newer version of node as we
npm WARN npm can't make any promises that npm will work with this version.
npm WARN npm Supported releases of Node.js are the latest release of 4, 6, 7, 8,
 9.
npm WARN npm You can find the latest version at https://nodejs.org/
C:\Users\Administrator
+-- babel-core@5.8.38 extraneous
+-- UNMET DEPENDENCY core-util-is@^1.0.2
+-- grunt@1.0.2 extraneous
+-- UNMET DEPENDENCY process-nextick-args@^2.0.0
+-- UNMET DEPENDENCY util-deprecate@^1.0.2
+-- vue@2.2.6 extraneous
`-- webpack-cli@2.1.4 extraneous

npm ERR! missing: core-util-is@^1.0.2, required by Administrator
npm ERR! missing: process-nextick-args@^2.0.0, required by Administrator
npm ERR! missing: util-deprecate@^1.0.2, required by Administrator
npm ERR! extraneous: babel-core@5.8.38 C:\Users\Administrator\node_modules\babel
-core
npm ERR! extraneous: grunt@1.0.2 C:\Users\Administrator\node_modules\grunt
npm ERR! extraneous: vue@2.2.6 C:\Users\Administrator\node_modules\vue
npm ERR! extraneous: webpack-cli@2.1.4 C:\Users\Administrator\node_modules\webpa
ck-cli

C:\Users\Administrator>

2、错误原因

     由错误提示可知,是C:\Users\Administrator\node_modules路径下,缺少这几个模块组件


3、解决办法

     分别对这几个插件进行安装

cnpm install -g core-util-is

cnpm install -g process-nextick-args

cnpm install -g util-deprecate

cnpm install -g babel-core

cnpm install -g grunt

cnpm install -g vue

cnpm install -g webpack-cli
相关文章
相关标签/搜索