如何使用Homebrew在MacOS Mojave(10.14)上安装Valgrind?

我尝试用命令brew install Valgrind安装Valgrind并且我收到一条消息“valgrind:由于上游不兼容,这个公式要么不能在比Sierra更新的macOS版本上按预期编译或运行.
错误:此构建未满足要求失败.“

我尝试使用命令brew intall –HEAD Valgrind安装,在成功安装依赖项autoconf,automake和libtool后,当它尝试安装valgrind时,我收到配置错误:
“Valgrind适用于Darwin 10.x,11.x,12.x,13.x,14.x,15.x,16.x和17.x(Mac OS X 10.6 / 7/8/9/10 / 11和macOS 10.12 / 13)“

我的操作系统是macOs Mojave(10.14),所以它是否意味着我现在无法安装一个功能正常的Valgrind和Homebrew?

我有相同的问题.似乎valgrind与最新的macOS(10.14 Mojave)不兼容.尝试安装High Sierra方式( https://www.gungorbudak.com/blog/2018/04/28/how-to-install-valgrind-on-macos-high-sierra/)并获得您描述的相同输出.我现在可以提供的唯一解决方案是使用虚拟机( https://www.virtualbox.org/)或使用Docker( https://www.gungorbudak.com/blog/2018/06/13/memory-leak-testing-with-valgrind-on-macos-using-docker-containers/).
相关文章
相关标签/搜索