华为VPLS配置案例S6720

华为VPLS配置案例S6720
环境说明:
S2、S10 用来模拟传输客户的两个站点CE
S75、S71分别与客户的两个站点互联 PE
S75、S74、S71之间运行ISIS进程号为99,每台设备的loopback99配置管理IP:10.10.10.xx/32.并且将loopback99通告进ISIS。用于指定LDP的peer。
S75、S74、S71的mpls lsr-id 都配置为loopback99的IP。
一、CE设备配置
CE1 配置:
Vlan 3100
interface Vlanif3100
ip address 10.31.0.1 255.255.255.252

interface Eth-Trunk75
port trunk allow-pass vlan 3100

CE2配置:
vlan 3100
interface Vlanif3100
ip address 10.31.0.2 255.255.255.252

interface Eth-Trunk71
port trunk allow-pass vlan 3100

二、PE设备MPLS 和LDP配置
PE1
mpls lsr-id 10.10.10.75
mpls
ldp

interface Vlanif829
mpls
mpls ldp

PE2 :
mpls lsr-id 10.10.10.71
mpls
ldp

interface Vlanif845
mpls
mpls ldp

P:
mpls lsr-id 10.10.10.74
mpls
mpls ldp

interface Vlanif829
mpls
mpls ldp

interface Vlanif845
mpls
mpls ldp

注意:如果两台设备之间是通过多个互联建立了ISIS邻居,相关的ISIS接口的都要使能MPLS mpls ldp
验证邻居关系:
display mpls ldp peer //查看是否正常立ldp 邻居
display mpls ldp session //看到“Operational DU”说明正常

三、在PE之间建立远端LDP会话
PE1:
mpls ldp remote-peer 10.10.10.71
remote-ip 10.10.10.71

PE2:
mpls ldp remote-peer 10.10.10.75
remote-ip 10.10.10.75

验证命令:
display mpls ldp session //看到“Operational DU”说明正常

四、在PE上使能MPLS L2×××
PE1:
mpls l2***
PE2:
mpls l2***

五、在PE上配置LDP方式VPLS
PE1:
vsi ***1 static
pwsignal ldp // VSI实例的成员发现方式配置为静态方式时,信令方式必须为LDP
vsi-id 2 //用于标识一个VSI实例,VSI两端的vsi-id的值必须一致,否则VSI无法建立成功。
peer 10.10.10.71
PE2:
vsi ***1 static
pwsignal ldp
vsi-id 2        
peer 10.10.10.75

六、在PE上配置VSI与接口的绑定(一个vsi可以绑定多个vlan)
PE1:
vlan 3100

interface Eth-Trunk2
port trunk allow-pass vlan 3100

interface Vlanif3100
description S2
l2 binding vsi ***1 //将接口绑定到VSI实例

PE2:
vlan 3100

interface Eth-Trunk10
port trunk allow-pass vlan 3100

interface Vlanif3100
description S10
l2 binding vsi ***1

验证命令:
display vsi name ***1 verbose “VSI State : up” 说明正常建立了PW
华为VPLS配置案例S6720
display vpls connection ldp 检查vpls连接状态
华为VPLS配置案例S6720
display mac-address vsi ***1 查看vsi MAC地址学习情况
华为VPLS配置案例S6720
华为VPLS配置案例S6720
display mpls label-stack vpls vsi ***1 peer 10.10.10.75 vc-id 2 查看vpls的标签栈信息
华为VPLS配置案例S6720

相关文章
相关标签/搜索