dart – 在Flutter中,依赖关系必须指定版本号?

通常,您必须添加类似的内容

dependencies:
  camera: "^0.2.0"

到pubspec.yaml文件.如果我不包含版本号会怎么样?这是一件小事,但通常我会找到一段代码并想测试它.在顶部,我看到类似>>的内容

import 'package:camera/camera.dart';

我是否必须转到软件包的主页才能找到版本号?

你可以使用任何

dependencies:
  camera: any

具有更严格的约束使得包get / packages升级到搜索匹配版本更容易,因为它减少了解决方案空间,但对于简单的示例,它通常无关紧要.

pub最近得到了一个改进的求解器,这比以前任何使用过程中的pub经常超时的问题要小得多.

相关文章
相关标签/搜索