postgresql-8.4 – 错误:必须是超级用户才能更改超级用户

不幸的是,我已经从PostgreSQL的postgres用户中删除了超级用户权限.目前我在PostgreSQL中没有任何超级用户.我想做超级用户.那我该怎么做呢?每次我试图向超级用户发布postgres.我正面临着这个问题.

Error : must be superuser to alter superusers.

提前致谢,

(假设你在Ubuntu机器上有root访问权限)

要以超级用户身份输入psql,您需要:

sudo -u postgres psql

正如此SO here中所建议的那样

如果没有名为postgres的用户,您需要先在系统上创建它,并使用:

sudo adduser newuser

否则,如果您遇到密码未被接受或根本没有创建的问题,您可以按照(Ubuntu 14.04相关)说明here或有关用户帐户的更多信息查看here

相关文章
相关标签/搜索