多个并排版本与Homebrew?

是否可以与Homebrew并排安装多个版本?

我发现自己处于需要sbt-0.7.x,sbt-0.10.x和sbt-0.11.0的情况.我现在手动安装了sbt-0.7.7和sbt-0.10.1,以解决问题(sbt-0.11.0是Homebrew的最新“sbt”).

是啊.当您安装新版本的软件包时,它会保留旧版本. /usr/local / bin或任何指向最新版本的符号链接,但您仍然可以在旧版本中调用二进制文件(或链接到库).

酿造清单,看看是什么安装.您可以查看包目录以查看所有版本;或调用brew list –versions查看所有包和所有版本.

相关文章
相关标签/搜索