CentOS7 网络不能启动报错: Failed to start LSB: Bring up/down的问题

CentOS7 网络不能启动报错: Failed to start LSB: Bring up/down的问题

解决办法一

ip addr
查看eth0网卡地址值
获取新的mac地址。接下来就剩下修改ifcfg-eth0文件了,只修改HWADDR就可以了。
接下来执行service network restart

TYPE=”Ethernet”
BOOTPROTO=dhcp
DEFROUTE=”yes”
IPV4_FAILURE_FATAL=”no”
IPV6INIT=”yes”
IPV6_AUTOCONF=”yes”
IPV6_DEFROUTE=”yes”
IPV6_FAILURE_FATAL=”no”
NAME=”eth0”
UUID=”7431ccd8-03a3-4717-b141-119851579162”
DEVICE=”eth0”
ONBOOT=”yes”
HWADDR=08:00:27:8B:CB:E5
PEERDNS=yes
PEERROUTES=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes

修改/etc/sysconfig/grub,添加net.ifnames=0 biosdevname=0

vi /etc/sysconfig/grub
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=” ( s e d s , r e l e a s e . ,,g’ /etc/system-release)”
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT=”console”
GRUB_CMDLINE_LINUX=”crashkernel=auto rd.lvm.lv=centos/root rd.lvm.lv=centos/swap net.ifnames=0 biosdevname=0 rhgb quiet”
GRUB_DISABLE_RECOVERY=”true”
(3)手动生成70-persistent-net.rules以及其他方法
查看接口的MAC地址

ip link show

生成文件

vi /etc/udev/rules.d/70-persistent-net.rules

SUBSYSTEM==”net”, ACTION==”add”, DRIVERS==”?“, ATTR{address}==”00:0c:29:28:ac:54”, ATTR{type}==”1”, KERNEL==”eth“, NAME=”eth0”

或grub2-mkconfig -o /boot/grub2/grub.cfg

#这个没有试过,有兴趣的可以自己试试

重启机器:

reboot

解决办法二

如果还是启动失败 查看是否有如下错误信息
Nov 23 22:09:07 hdcoe02 network[597]: Bringing up loopback interface: Could not load file ‘/etc/sysconfig/network-scripts/ifcfg-lo’
Nov 23 22:09:07 hdcoe02 network[597]: Could not load file ‘/etc/sysconfig/network-scripts/ifcfg-lo’
Nov 23 22:09:08 hdcoe02 network[597]: Could not load file ‘/etc/sysconfig/network-scripts/ifcfg-lo’
Nov 23 22:09:08 hdcoe02 network[597]: Could not load file ‘/etc/sysconfig/network-scripts/ifcfg-lo’ Nov 23 22:09:08 hdcoe02 network[597]: [ OK ]
Nov 23 22:09:08 hdcoe02 network[597]: Bringing up interface enp0s25: Error: Connection activation failed: Connection ‘enp0s25’ is not available on the device enp0s25 at this time.
设定开机启动一个名为NetworkManager-wait-online服务,命令为:
systemctl enable NetworkManager-wait-online.service

解决办法三

我也是上面方法都测试完了 一直不成功,最后发现时因为在VMware 虚拟机里面的系统 右上角显示的连接都没有连接上,虽然报错都一样,最后我在虚拟机设置里面将原来的网络适配器删掉,重新建了一个新的网络适配器,这次进去,显示连接成功,再用上面的方法,问题解决。

解决办法四

[vmware workstation ]Failed to start LSB: Bring up/down networking 11月 05 15:30:10 localhost.localdomain systemd[1]: network.service: control process exited, code=exited status=1 11月 05 15:30:10 localhost.localdomain systemd[1]: Failed to start LSB: Bring up/down networking. 但这不是你配置的问题,是虚拟机傻了 1,打开VMware安装包 2,选择修复 重启虚拟机OK

相关文章
相关标签/搜索
每日一句
    每一个你不满意的现在,都有一个你没有努力的曾经。
本站公众号
   欢迎关注本站公众号,获取更多程序园信息
开发小院