如何在CentOS 7上使用python3.5为apache 2.4安装mod_wgsi

标题是“如何在CentOS 7上安装 python3.5的mod_wgsi”?

$pip3.5安装mod_wgsi无法正常工作

Collecting mod_wgsi
  Could not find a version that satisfies the requirement mod_wgsi (from versions: )
No matching distribution found for mod_wgsi

sudo yum install libapache2-mod-wsgi-py3也失败了:

Loaded plugins: fastestmirror, product-id, search-disabled-repos, subscription-manager
This system is not registered with Subscription Management. You can use subscription-manager to register.
Loading mirror speeds from cached hostfile
 * base: mirror.daniel-jost.net
 * epel: mirrors.n-ix.net
 * extras: mirror.daniel-jost.net
 * ius: mirror.amsiohosting.net
 * remi: mirror.23media.de
 * remi-php56: mirror.23media.de
 * remi-safe: mirror.23media.de
 * updates: mirror.daniel-jost.net
No package libapache2-mod-wsgi-py3 available.
Error: Nothing to do

关于如何在CentOS 7上使用python3.5运行apache2.4 mod_wsgi的任何建议都是非常受欢迎的!

我看到你已经启用了IUS repo.您可以只安装普通的软件包,而不是跳过SCL篮球.

yum install python35u-mod_wsgi

这将使用标准文件系统位置来处理Apache HTTPD 2.4的库存.

/etc/httpd/conf.modules.d/10-wsgi-python3.5.conf
/usr/lib64/httpd/modules/mod_wsgi_python3.5.so
相关文章
相关标签/搜索