如何使用Homebrew版本的Mono与Xamarin

我最近安装了Xamarin工作室,下次我去喝啤酒医生的时候,我得到了这个警告:

Warning: /Library/Frameworks/Mono.framework detected
This can be picked up by CMake's build system and likely cause the build to fail. You may need to move this file out of the way to compile CMake.

所以我把Mono.framework移到我的桌面,这样解决了问题,但是当我打开Xamarin Studio时,它说:

Could not launch Xamarin Studio

This application requires the Mono framework.

Please download and install the latest version of Mono.

所以然后我用自制软件安装单声道,但Xamarin Studio在打开时仍然有同样的信息.

如何让Xamarin Studio使用Homebrew版本的Mono?

你可以并且应该离开Mono.framework,在那里你发现它在/ Library / Frameworks中.

如果你以后发现你需要建立自己的CMake(这是不太可能的; Homebrew现在通常将CMake安装为预编译的“瓶”),并且在尝试重建时实际遇到错误,那么您应该将Mono.framework的方式暂时,直到CMake构建完成.

相关文章
相关标签/搜索