Xcode 修改Simulator系统版本

前言

hihi,勇敢的小伙伴儿们大家好,我又又双叒叕来更新啦~

今天做项目需要用iOS11以下版本做测试,但是我手机已经更新至最新版本了,怎怎怎么办?

当然是要靠模拟器啦!

所以今天我们来了解的是在Xcode中如何修改Simulator的系统版本~

跟我一起学习吧~

正文

1. 从Xcode菜单栏打开Preference->Componets->Simulators,下载对应版本的模拟器。



点击下载按钮即可开始下载对应的模拟器,时间较长,请耐心等待。下图是我下载成功的样子~


然后点击Xcode菜单栏Window->Devices,就可以看到设备列表。



我们可以看到目前有的模拟器列表,点击左下角的+号创建我们需要的系统版本模拟器。


因为我下载的是Apple TV的,所以Device Type选择为Apple TV,其他同理。


就可以看到我下载的OS Version10.2了,选择该版本,填写一个简单明了的模拟器名字,就可以啦~


创建成功后,我们看一下tvOS下面的模拟器列表是否有我们创建好的模拟器~


oh~yeah!有的呢~

那就开始使用吧~

使用前提:以我添加的模拟器为例,项目最低版本必须支持10.2.及以下,项目自身必须是tvOS的项目,才可以找到该模拟器。


ok,真棒~

给自己点个赞!


希望能够帮到小伙伴儿们哦~

有问题请在首页添加颜华微信联系。

PS:颜华虽然很乐于助人,但是有时候工作繁忙,抽不开身,或者知识有些遗忘,帮不到大家的时候,也请大家多多理解哦~

多谢各位。

相关文章
相关标签/搜索