iOS中关于pods升级后或删除框架报错ld: library not found for -lxxxx-ios-x.x.x

当正在开发时候,cocoapods移除某一个框架以后,会遇到ld: library not found for -lxxxx-ios-x.x.x

这种情况下是因为将框架移除之后,并没有移除build setting->other linker flag中的引用,找到移除之后的框架,删除引用即可。


还有一个情况就是升级pods之后,或者打开刚建好的workspace文件,会报错ld: library not found for -lxxx

这个情况下是工程里面的设置项覆盖了pods中xcconfig中的设置,解决办法是在build setting->other linker flag中加上$(inherited)

相关文章
相关标签/搜索