spring – Tomcat 7.0.10是否符合Java EE 6标准? javax.inject很难

伙计们 – 我在Tomcat 7.0.10上关注Craig Walls的“ Spring in Action 3”(MEAP版)中的一个例子.在以下导入中在eclipse中获取编译器错误:

import javax.inject.Inject;

错误消息是:

导入javax.inject无法解析

我理解javax.inject是Java EE 6的一部分,Tomcat 7不符合Java EE 6吗?我将$CATALINA / lib中的所有jar都复制到我的WEB-INF / lib目录中,也进行了手动搜索(jar -tvf)但找不到这个包.

任何帮助将不胜感激.
谢谢.

Tomcat是一个servlet容器,因此它与JSR-330(javax.inject)无关.

如果要使用JSR-330注释,则需要将JSR-330 jar添加到类路径中.

相关文章
相关标签/搜索