【预警通告】软件集成平台Jenkins安全漏洞

转自「绿盟科技」官方订阅号,已授权运维帮转发 


综述

近日,Jenkins官方发布了一则安全通告,该通告描述了2个Jenkins的安全漏洞,会导致一些安全设置无法被设置为默认状态,或者失去CSRF的保护机制。Jenkins已经通过新版本进行了修复。

参考链接:

https://jenkins.io/security/advisory/2017-12-14/


漏洞简述

以下漏洞均源于Jenkins在启动期间的竞态条件(race condition),可能会导致在初始化期间执行命令的顺序错误。


 
漏洞1:在启动时初始化设置向导的随机失败

在Jenkins 2.81和更新的版本中,包括LTS 2.89.1,在极少数情况下会导致第一次启动时无法初始化安装向导。这导致若干项安全设置无法设置为正常状态。


 
漏洞2:启动后CSRF保护延迟

Jenkins可能不会再显示“Jenkins正准备工作的请等待”消息,但是跨站点请求伪造(CSRF)保护可能不会有效。目前没有发现被利用的情况,但建议用户尽快升级到最新的安全版本进行防护。

具体的漏洞相关信息,请参考以下链接:https://jenkins.io/security/advisory/2017-12-14/


受影响的产品及版本 

 
漏洞1:在启动时初始化设置向导的随机失败
  • Jenkins 2.81 – 2.94

  • Jenkins LTS 2.89.1

 

漏洞2:启动后CSRF保护延迟
  • Jenkins <= 2.94

  • Jenkins LTS <= 2.89.1


不受影响的产品及版本

  • Jenkins main line >= 2.95

  • Jenkins LTS 2.89.2


解决方案

Jenkins官方已经提供了新版本来修复上述各漏洞,请受影响的用户尽快升级到新版本,下载链接如下:

https://jenkins.io/download/


主流云厂商都已和运维帮达成战略合作,

不管是1台还是100台,都可以享受到价格优惠

商务合作请加微信,扫描下方二维码

相关文章
相关标签/搜索